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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

l Procedures are presented as numbered lists. A single bullet indicates that the procedure
has only one step.

l Bold type is used for the following:
o Keyboard entries that should be typed in their entirety exactly as shown. For
example, “copy file1” means you must type the word copy, then type a space, and
then type file1.

o On-screen prompts and messages, names of options and text boxes, and menu
commands. Menu commands are often separated by greater than signs (>). For
example, “click HFSS > Excitations > Assign >Wave Port.”

o Labeled keys on the computer keyboard. For example, “Press Enter” means to
press the key labeled Enter.

l Italic type is used for the following:
o Emphasis.
o The titles of publications.
o Keyboard entries when a name or a variable must be typed in place of the words in
italics. For example, “copy filename” means you must type the word copy, then
type a space, and then type the name of the file.

l The plus sign (+) is used between keyboard keys to indicate that you should press the
keys at the same time. For example, “Press Shift+F1” means to press the Shift key and,
while holding it down, press the F1 key also. You should always depress the modifier key
or keys first (for example, Shift, Ctrl, Alt, or Ctrl+Shift), continue to hold it/them down, and
then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

l The Ribbon occupies the rectangular area at the top of the application window and con-
tains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Draw > Line"
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This instruction means that you should click the Line command on the Draw ribbon tab.
An image of the command icon, or a partial view of the ribbon, is often included with the
instruction.

l Themenu bar (located above the ribbon) is a group of the main commands of an applic-
ation arranged by category such File, Edit, View, Project, etc. An example of a typical user
interaction is as follows:

"On the Filemenu, click theOpen Examples command" means you can click the File
menu and then clickOpen Examples to launch the dialog box.

l Another alternative is to use the shortcut menu that appears when you click the right-
mouse button. An example of a typical user interaction is as follows:

“Right-click and select Assign Excitation >Wave Port” means when you click the right-
mouse button with an object face selected, you can execute the excitation commands
from the shortcut menu (and the corresponding sub-menus).

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. You can also contact your Ansys account manager in order to
obtain this information.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps were
taken or what stages the simulation reached, including software files as applicable. This allows
more rapid and effective debugging.

Help Menu

To access help from the Help menu, click Help and select from the menu:

l [product name] Help - opens the contents of the help. This help includes the help for the
product and itsGetting Started Guides.

l [product name] Scripting Help - opens the contents of the Scripting Guide.
l [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help from the user interface, press F1. The help specific to the active product (design
type) opens.

You can press F1 while the cursor is pointing at a menu command or while a particular dialog
box or dialog box tab is open. In this case, the help page associated with the command or open
dialog box is displayed automatically.
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1 - Introduction
This Getting Started guide describes how to create, solve, and analyze a bandpass filter.

By following the steps in this guide, you will learn how to perform the following tasks in HFSS:

l Become familiar with the HFSS Design Environment
l Create a 3D geometric model, including conducting bodies and a surrounding vacuum
region representing the bandpass filter enclosure

l Assign excitation
l Learn about High Performance Computing (HPC) options
l Analyze the model and review solution data,
l Create and modify a report (2D rectangular plot), including adjusting the plot scaling
l Create field overlays

Bandpass Filter Description
A bandpass filter allows frequencies of a certain range to pass through but attenuates those fre-
quencies outside of the bandpass range. The figure below is an illustration of a model rep-
resenting a bandpass filter and a volume of air surrounding it. The colors represent the electrical
field intensity around the conductors.

Figure 1-1: The Bandpass Filter Model

Getting Started with HFSS: Bandpass Filter
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HFSS Design Environment
There are many features in HFSS that enable you to create this model. Some of these features
are listed below:

l Three-dimensional (3D) solid modeling
l Primitives such as cylinders and boxes
l Modeling operations such as Duplicate Around Axis
l Boundaries and excitations
l Wave ports and terminals
l Design validation
l Solution setup and frequency sweep
l S-parameter plots
l Field Overlays to plot electromagnetic fields
l Two-dimensional (2D) and three-dimensional (3D) Field Plots

Introduction 1-2
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2 - Set Up the Project
This chapter includes the following sections:

l Launch Ansys Electronics Desktop
l Set General Options
l Insert HFSS design
l Enable Legacy View Orientations
l Set the Model Units
l Verify the Solution Type

For convenience, store a shortcut of the Ansys Electronics Desktop application on your desktop.

1. Double-click the Ansys Electronics Desktop icon to launch the application.

Set Up the Project 2-1
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Figure 2-1: Ansys Electronics Desktop User Interface

Note:

If the project folder is missing, go to the Desktop ribbon tab and click New to
start a new project. If the Project Manager window does not appear, go to the
View ribbon tab and enable it from the Docking Windows drop-down menu.

Set General Options
Before you begin creating a design, configure some of the general options of HFSS:

1. Go to the Desktop ribbon tab and select General Options.

TheOptions dialog box appears.

2. Expand the HFSS branch and select Boundary Assignment.

Figure 2-2: OptionsWindow – HFSS Boundary Assignment Settings

3. Ensure all checkboxes on this panel are selected.
4. Expand the 3D Modeler branch and select Drawing.

Set Up the Project 2-2
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Figure 2-3: OptionsWindow – 3D Modeler Drawing Settings

5. Select Automatically cover closed polylines.
6. Select Edit properties of new primitives.

Note:

This option causes a Properties dialog box to appear whenever you create a new
object.

7. Under 3D Modeler, expand the Display branch and select Rendering.
8. Ensure that the Use material appearance if available option is cleared and the Default

Transparency is 0.4.

Set Up the Project 2-3
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9. ClickOK to accept the options and close the dialog box.
 >

Insert HFSS design
1. On the Desktop ribbon tab, click HFSS from the HFSS drop-down menu to include this

design type in your project.

Figure 2-4: Insert HFSS Design – Command Location

An HFSSDesignx item appears in the Project Manager, theModeler window appears,
and the ribbon advances to the Draw tab.

Set Up the Project 2-4
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Figure 2-5: Electronics Desktop with the HFSS Design Type Added to the Project

2. Click Projectn in the Project Manager, then:
a. Press F2
b. Rename your project to Bandpass_Filter and press Enter.

Note:

From the menu bar, click View, point to Coordinate System, and click any of the
first three options in the submenu to adjust the displayed size of the coordinate
axes. You can also control the visibility of the axes from this menu. Similarly, you
can adjust grid visibility and style from theGrid Spacing dialog box that appears
when you click View >Grid Settings from the menu bar.

3. In any of the ribbon tabs, click Save to save your project. Even though Ansys Elec-
tronics Desktop autosaves your model periodically (every ten edits, by default), it's a good
idea to save your work frequently.

Set Up the Project 2-5
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Enable Legacy View Orientations
This getting started guide was created based on standard view orientations that were in effect
for version 2023 R2 and earlier of the Ansys Electronics Desktop application. For consistency
between your experience and the views and instructions contained in this guide, select the
Enable Legacy View Orientation option in the 3D UI Options dialog box, as follows:

1. From the menu bar, click View >Options.

The 3D UI Options dialog box appears.

2. Select Enable Legacy View Orientation:

3. ClickOK.

Changing the view orientation option does not change the model viewpoint that was in
effect at the time.

4. On the Draw ribbon tab, click Orient to change to the Trimetric view, which is the
default legacy view orientation.

Set Up the Project 2-6
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You do not have to select Trimetric from theOrient drop-down menu. The default view
appears when you clickOrient.

Although this option can only be accessed once a design is added to a project, it is a global
option. Your choice is retained for all future program sessions, projects, and design types that
use the 3D Modeler or that produce 3D plots of results.

At the end of this guide, you will be prompted to clear the Enable Legacy View Orientation
option, if you prefer to use the view orientation scheme implemented for 2024 R1 and newer ver-
sions going forward.

For a comparison of the legacy and current view orientations, search for "View Options: 3D UI
Options" in the HFSS help. Additionally, views associated with Alt + double-click zones have
been redefined. The current orientations are shown in the help topic, "Changing the Model View
with Alt+Double-Click Areas."

Set Model Units (in)
Define the model units as follows:

1. On the Draw ribbon tab, click Units.

The Set Model Units and Max Extents dialog box appears.

2. Select in (inches) from the Select units drop-down menu.

Keep Rescale to new units cleared and leave the Advanced option cleared, keeping the
default model extents of +/-10000 length units.

Figure 2-6: Set Model Units and Max Extents Dialog Box

3. ClickOK.

Verify Solution Type (Terminal)
Specify the design’s solution type as follows:

Set Up the Project 2-7
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1. On the menu bar, click HFSS > Solution Type.

The Solution Type dialog box appears.

Figure 2-7: Solution Type Dialog Box

2. Ensure that Terminal and Network Analysis are selected. Leave Auto-Open Region
cleared.

3. ClickOK.

Note:

The Terminal solution type calculates the terminal-based S-parameters of multi-
conductor transmission line ports. The S-matrix solutions are expressed in terms
of terminal voltages and currents.

Set Up the Project 2-8
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3 - Create the 3D Model
This chapter includes the following sections:

l Create the Enclosure (vacuum region)
l Create Feed1 (coax outer diameter)
l Create FeedPin1 (coax conductor)
l Create FeedProbe1
l Create the Resonators
l Assign Excitation
l Create Remainder of Model by Duplication
l Boundary Display (Optional)

The 3-D Model of the bandpass filter is made up of multiple geometrical parts, as listed above.

For the first two objects (Enclosure and Feed1), assign vacuum as the material. For all other
parts, assign the material pec (perfect electrical conductor). Each duplicated parts will retain the
same material assignment as the part from which it is copied.

Note:

l You can enter the coordinates and dimensions (height, radii, etc.), in the text
boxes at the bottom of the application while building the geometric objects.
However, you many find it more convenient to draw the objects freehand and
then edit their properties. The latter method is used in this exercise.

l If you want you can adjust the views of your coordinate system axes and grid
from the Viewmenu using the Coordinate System andGrid Settings options,
respectively. These controls, with the exception of grid visibility, are not available
from the ribbon.

Create the Enclosure
Normally, the region within which electromagnetic fields are calculated is a body comprised of
the material vacuum or air. In the last topic of this guide, you will perform a multipaction analysis
of the bandpass filter, which requires that the solution region be a vacuum.

To create the enclosure region, draw a box of any size freehand anywhere in theModeler win-
dow and then adjust its properties, as follows:

1. On the Draw ribbon tab, click the Box primitive.

The cursor changes to a snapping point indicator.

Create the 3D Model 3-1
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Figure 3-1: Snapping Point Indicator

2. Click anywhere in the 3D Modeler window to establish the starting point.
3. Drag your cursor along the XY plane, and click a second time to create the base:

Figure 3-2: The Arrow is the Mini Z Axis.

4. Drag the cursor along the Z axis direction:

Create the 3D Model 3-2
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Figure 3-3: Box Height Being Dragged Upward

5. Click a third time to set the height and complete the box:

Figure 3-4: Box Drawn – After the Final Mouse Click

The Properties dialog box appears.

6. On the Command tab, edit the Value table cells as shown in the following figure:

Figure 3-5: Command Tab for the First Box

7. On the Attribute tab rename Box1 to Enclosure.
8. Ensure that the selectedMaterial is vacuum.
9. Set the Transparency to 0.8 and clickOK to close the Set Transparency dialog box.
10. ClickOK to apply the new box properties and close the Properties dialog box.
11. Click in theModeler window's background area to deselect the enclosure.

Create the 3D Model 3-3
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12. Press CTRL+D, or click Fit All on the Draw ribbon tab, to fit the view in the Modeler win-
dow.

Note:

As you continue to build the model, use one of these two methods of fitting the
model to the canvas area as needed.

Figure 3-6: The Completed Enclosure Object

History Tree and Docked Properties Window
When you select a 3D or a 2D object in the history tree, its details can be readily viewed in the
docked Properties window. For instance, if you select Enclosure in the History Tree, its details
are displayed in the docked Properties window. To enable this window, go to the View ribbon tab
and select Properties from the Docking Windows drop-down menu.

Create the 3D Model 3-4
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Figure 3-7: Docked Properties Window

Create Feed1
Feed1 is a cylindrical object representing the vacuum portion of the feed coax. You will add a
conductor at the center of the coax in a later procedure.

To create Feed1, draw a cylinder freehand and then adjust its properties, as described below:

1. Click the Draw tab and select YZ underGrid to set the drawing plane.

The active plane changes to YZ.

2. On the Draw ribbon tab, click the Cylinder primitive and create the cylinder any size and
anywhere in the Modeler window.

Create the 3D Model 3-5
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Note:

In this case, draw the circular cross-section first and then draw the length.

3. On the Command tab of the Properties dialog box, edit the fields as shown in the fol-
lowing figure:

Figure 3-8: Command Tab – Properties for Feed1

4. On the Attribute tab rename the cylinder to Feed1 and ensure that the material vacuum
is assigned.

5. ClickOK to complete the cylinder.

Create the 3D Model 3-6
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Figure 3-9: Feed1 Created

Create FeedPin1
You can pick a different material from the library before creating new geometry. This technique is
convenient when you are going to create several objects of the same material.

After choosing the desired material, create the feed pin, which is the conductor at the center of
the feed coax. Draw a cylinder freehand and then modify its properties.

You do not need to subtract the feed pin from the previously created feed object. The solver will
perform implicit subtraction, removing the conductor volume from the vacuum object where they
overlap.

1. On the Draw ribbon tab, click Select from the Default material drop-down menu.

The Select Definitions window appears.

Create the 3D Model 3-7
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Figure 3-10: Select Definitions Window

Then, do the following:

a. Type pec in the Search by Name. The materials list scrolls to the pecmaterial, and
it is selected.

b. ClickOK to accept the material selection.

The default material is set to pec and the Select Definition dialog box closes. All
future objects you create in this project will default to this material until you change
the selection again.

2. Draw a cylinder freehand and edit the fields on the Command tab of the Properties dialog
box, as shown in the following figure:

Figure 3-11: FeedPin1 Properties – Command Tab

3. On the Attribute tab, rename object to FeedPin1 and clickOK.

Create the 3D Model 3-8
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Figure 3-12: FeedPin1 Created.

Create FeedProbe1
The feed probe connects FeedPin1 to the first resonator, L1, which you will draw in the next
topic.

Note:

Alternatively, you could have created FeedPin1 longer, to extend all the way to L1, elim-
inating the necessity of the feed probe. However, boundary errors would occur
because the extended feed pin would cross through the outer boundaries of both
Feed1 and Enclosure. To prevent the errors, you would have to subtract FeedPin1
from Feed1 and Enclosure (to eliminate the overlap).

The feed probe, on the other hand, is fully encompassed by the enclosure by design.
Therefore, implicit subtraction takes care of the object overlap, neither the feed pin nor
feed probe crosses the enclosure boundary, and no boundary errors occur.

Create FeedProbe1 as follows:

1. Draw a cylinder freehand and edit the fields on the Command tab of the Properties dialog
box, as shown in the following figure:

Create the 3D Model 3-9
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Figure 3-13: Coax FeedProbe1 Properties – Command Tab

2. On the Attribute tab rename the object as FeedProbe1 and clickOK.

Figure 3-14: FeedProbe1 Added.

Create the Resonators
Draw four resonators for this model. For each resonator, draw a box freehand and place it appro-
priately in the structure you've drawn up to this point.

There are a total of eight resonators in the subject bandpass filter. Four you create manually,
and the other four (along with the feed and probe objects) you make by duplicating the manually
created objects.

The resonators are the heart of the bandpass filter. The varying gaps between them and the
alternating axial offset of each resonator produce the desired bandpass filter behavior (allowing
frequencies of a certain range to pass freely while attenuating frequencies outside of the target
range).

Create the 3D Model 3-10

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS: Bandpass Filter

Create L1
1. Draw a box freehand and edit the fields in the Command tab of the Properties dialog box,

as shown in the following figure:

Figure 3-15: Resonator L1 Properties – Command Tab

2. On the Attribute tab, rename the object as L1 and clickOK.

Figure 3-16: The First Resonator (L1) Created

Create L2
Let's look at two different methods for creating the second resonator,

Method 1 – Draw Freehand and Revise its Properties

1. In the same way that you created L1, draw a box freehand.

The Properties dialog box appears.

2. On the Attribute tab, rename the object as L2.
3. On the Command tab, edit the L2 property fields as shown in the following figure:

Create the 3D Model 3-11
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Figure 3-17: Resonator L2 Properties – Command Tab

4. ClickOK.

Method 2 – Copy L1 and Revise the New Object's Properties:

1. UnderModel > Solids > pec in the History Tree, right-click L1 and choose Edit > Copy
from the shortcut menu.

2. Right-click in the Modeler window and click Edit > Paste. Object L2 appears in the History
Tree, but it is not in the correct location in the model.

(The advantages of this method are that the name L1 is automatically incremented to L2
for the new object, and the XSize and YSize dimensions of the new box are already cor-
rect.)

When you create a primitive by copying and pasting an existing object, the Properties dia-
log box does not appear automatically. Therefore, you will change the settings in the
docked Properties window.

3. In the Command tab of the docked Properties window, edit the L2 property fields as
shown in the following figure:

Figure 3-18: Resonator L2 Properties – Command Tab

4. ClickOK.

Regardless of the method you use, the model should now look like the following figure:

Create the 3D Model 3-12
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Figure 3-19: The Second Resonator (L2 Created

Create L3
1. Using your preferred method (1 or 2), as described in the Create L2 page, create the third

resonator (L3).

Tip:

L2 is the more efficient source for copying to L3, since L2 has the most similar
dimensions and coordinates compared to L3. Beware though that some values
have the same magnitudes but different signs.

2. If you drew the box freehand:

In the Attributes tab of the Properties dialog box, rename the object to L3.

Keep the Properties dialog box open.

3. In the Command tab of either the Properties dialog box or the docked Properties window
(depending on your drawing method), edit the position and sizes as shown in the following
figure:

Create the 3D Model 3-13

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS: Bandpass Filter

Figure 3-20: Resonator L3 Properties – Command Tab

4. If you drew the box freehand:

ClickOK to close the Properties dialog box.

Regardless of your drawing method, the model should now look like the following figure:

Figure 3-21: The Third Resonator (L3) Created

Create L4
1. Using your preferred method (1 or 2), as described in the Create L2 page, create the

fourth resonator (L4).

Tip:

L2 is the more efficient source for copying to L4, since L2 has the most similar
dimensions and coordinates compared to L4.

2. If you drew the box freehand:

In the Attributes tab of the Properties dialog box, rename the object to L4.

Keep the Properties dialog box open.

3. In the Command tab of either the Properties dialog box or the docked Properties window
(depending on your drawing method), edit the position and sizes as shown in the following
figure:
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Figure 3-22: Resonator L4 Properties – Command Tab

4. If you drew the box freehand:

ClickOK to close the Properties dialog box.

Regardless of your drawing method, the model should now look like the following figure:

Figure 3-23: The Fourth Resonator (L4) Created

Assign Excitation
Use wave ports to excite the outer face of the coax connector as described below.

1. To enter face selection mode, press the hotkey F on your keyboard.
2. Select the outer face of the coax line as shown below.
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Figure 3-24: Face Selected to Assign Wave Port

3. With the face selected, right click and go to Assign Excitation > Port > Terminal Wave
Port in the short-cut menu.

The Reference Conductors for Terminals dialog box appears.

4. Enter the port name (P1) and select the option Use port object name, as shown in the fol-
lowing image. Then, clickOK.
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Figure 3-25: Reference Conductors for Terminals

The wave port and feed terminal are assigned, and both items appear in the Project Man-
ager under Excitations.

Figure 3-26: Project Manager – Excitations Branch

5. Select FeedPin1_T1 in the Project Manager and press F2 to rename the terminal. Make
the new name T1 and press Enter.

Create the 3D Model 3-17

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS: Bandpass Filter

Note:

Simplifying the name of the terminal will make the selection of the parameters to
plot easier and the plot legend text shorter.

6. Select P1 or T1 in the Project Manager to see the port or terminal visualization, respect-
ively:

Figure 3-27: Close-up View of Port and Terminal Assignments

Create Rest of the Model by Duplication
At this point, you are almost through with the drawing of your model. All you need to do now is
duplicate the internal objects that you drew to create the remaining object. The steps are as fol-
lows.

1. To enter object selection mode, press the hotkeyO on your keyboard.

Note:

Alternatively, chooseObject from the Select drop-down menu on the Draw rib-
bon tab.
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2. Click Select by Name on the Draw tab.

The Select Object dialog box appears.

3. Select the following objects and clickOK:

Feed1, FeedPin1, FeedProbe1, L1, L2, L3, and L4.

Figure 3-28: Select Object Dialog Box

4. With the objects selected, right-click and select Edit > Duplicate > Around Axis from the
short-cut menu.

The Duplicate Around Axis dialog box appears.

5. Select Z as the Axis, specify as 180 deg for the Angle, and 2 as the Total number, as
shown in the following figure. Then, clickOK.
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Figure 3-29: Duplicate Around Axis Z

6. ClickOK to close the Properties dialog box that appears.
7. Click in the Modeler window background area to clear the current selection.

The bandpass filter model should now look like the following figure. Observe that even the
ports and terminals are duplicated and the Excitations branch of the Project Manager is
updated. The wave port and terminal names are automatically incremented to P2 and T2,
respectively.

Figure 3-30: Duplication of the Parts
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Boundary Display (Optional)
Boundary display/solver view provides a snapshot of all boundaries in the model including ports
and surface residing on the surrounding background object. It can be very useful for diagnosing
problems with design setups.

1. On the menu bar click HFSS > Boundary Display (Solver View).

The Solver View of Boundaries dialog box appears.

HFSS identifies all the unique boundary conditions and ports to display where the bound-
aries are physically located in the model.

Figure 3-31: Solver View of Boundaries Dialog Box

2. Click the Visibility check box for the boundaries you wish to display.
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Note:

The Enclosure is displayed as the outer boundary, and the perfect conductors
are displayed as the smetal boundaries. If you want, you can change any color
from the palette that appears when you double-click a cell in the Color column.

In the following figure, Visibility is enabled for all of the smetal parts but not for the ports or
outer boundary:

Figure 3-32: Boundaries Displayed

3. On the Solver View of Boundaries dialog box, click Close.

On the View ribbon tab, click Hide/Show overlaid visualization in the active view
option.

The Active View Visibility dialog box appears.
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Figure 3-33: Active View Visibility Dialog Box

4. In the 3D Modeler tab, deselect Visibility for any objects that you don't want to see.

Note:

You can use wildcards (* or ?) in the Name field to quickly show or hide multiple
objects. For example, you could use the name L?_1 to show or hide all the duplic-
ate resonator parts in a single operation. In the Excitations tab, you can also
show or hide excitations that you've applied to the model.

5. On the Active View Visibility dialog box, verify that Visibility is checked for all the objects
under the 3D Modeler tab and click Done.
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4 - Set Up and Analyze the Model
This chapter includes the following sections and subsections:

l Add Solution Setup and Frequency Sweep
l Add HPC Analysis Setup
l Validate and Analyze the Bandpass Filter
l Review Solution Data

l Review Profile Panel
l Review Convergence Panel
l Review Matrix Data Panel
l Review Mesh Statistics Panel

Add Solution Setup and Frequency Sweep
1. On the Simulation ribbon tab, click Setup > Advanced:

The Driven Solution Setup dialog box appears.

2. Edit the fields on theGeneral tab, as shown in the following figure:
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Figure 4-1: Driven Solution Setup Dialog Box – General Tab

Note:

This dialog box defines how HFSS automatically generates an accurate mesh
and helps you define the stopping criteria for the mesh adaptation process.

3. ClickOK.

For models that include any type of assigned port excitation, upon completing the addition
of an advanced solution setup, the Edit Frequency Sweep dialog box appears auto-
matically.

4. Edit the fields as shown in the following figure. Then, clickOK.
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Figure 4-2: Edit Frequency Sweep Dialog Box

Note:

The Sweep Type is set to Interpolating because the two-octave bandwidth over
which we're solving is a bit wide for the Fast sweep type.

Setup1 and its Sweep are listed under Analysis in the Project Manager.

5. Save the Project.

Add HPC Analysis Setup
HFSS provides the HPC and Analysis Options setup for the purpose of High Performance
Computing, which ensures efficient simulation. Since you are solving a frequency sweep in this
design, using HPC distributes the frequencies across available cores, making optimum use of
the computer resources.
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Note:

Ignore this section if you do not want to use HPC.

1. Go to the Simulation ribbon tab and select HPC Options, as shown in the following fig-
ure.

Figure 4-3: Access HPC and Analysis Options

The HPC and Analysis Options dialog box appears.

Figure 4-4: HPC and Analysis Options
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2. Select the Design Type for which you want to set up HPC from the drop-down menu, if
the correct type is not already selected.

Figure 4-5: Design Type for HPC and Analysis Options

3. Click the Add button.

The Analysis Configuration dialog box appears, as shown in the following figure:
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Figure 4-6: Analysis Configuration Dialog Box

4. Enter a name in the Configuration name text box.

Figure 4-7: Set the Configuration Name

5. Select Use Automatic Settings.

Based on the best use of available resources for the current analysis, this setting auto-
matically selects the number of parallel tasks.

6. In theMachine Details panel, select Local Machine and click Add Machine to List.
7. Set the total number of Cores to agree with the number of physical processor cores that

are included in your computer. The following image shows the appropriate setting for a
12-core PC:

Figure 4-8: Number of Cores

Note:

l You will achieve the best performance if hyperthreading is disabled in your
system BIOS. For computationally intensive applications, such as finite ele-
ment analysis, it is best to give a full physical core to each task. Hyper-
threading causes two or more tasks to be assigned to a single physical
processor core.

l The number of tasks is based on a factor associated with the total cores.
On a machine with 12 available cores, when the number of tasks is 4,
optimum use of the available cores happens. However, if the number of
tasks is 5, of the 12 available cores 2 remain idle.
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8. Leave the Num variations to distribute setting and the default settings in theOptions
tab as they are and clickOK.

In the HPC and Analysis Options dialog box, the Available Configurations and Con-
figuration Details panels have been updated with the configuration you just created.

9. Select the row that was just added to the Available Configurations list. Identify it by the
name you specified in step 4. Then, clickMake Active if this configuration is not already
the active one. The dialog box should now look like the following image:

10. ClickOK to complete the HPC configuration and close the dialog box.

What HFSS Does with the HPC Configuration
HFSS intelligently determines which jobs are to be performed and how to distribute them for the
simulation. It automatically apportions the jobs during the simulation process and makes
optimum use of the available resources.

For this HPC configuration, first HFSS uses 12 cores of matrix multiprocessing for the adaptive
mesh generation. The number of cores used for solving each frequency point is determined by
Total Cores/Number of Tasks. So, after adaptive mesh generation HFSS uses the same 12
cores during the frequency sweep by running 4 frequency points in parallel with 3 cores matrix-
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multiprocessing per frequency point. This solves faster since running frequency points in parallel
ensures a more scalable HPC technology than matrix-multiprocessing alone. However, since 4
frequency points are solved in parallel the analysis uses 4 times the memory of the last adaptive
pass. So, it is assumed that the machine has adequate memory to solve the 4 frequency points.
As an alternative you can use HPC to leverage cores on networked physical nodes, which can
provide the additional memory for the parallel frequency points.

Of course, for your PC and HPC configuration, the number of cores and the resultant computing
scheme may be different.

Validate and Analyze the Bandpass Filter
The model has to pass the validation check to confirm your design is set up correctly before you
analyze it.

1. Click Validate on the Simulation ribbon tab.

The Validation Check dialog box appears.

Note:

In HFSS projects, warnings might appear in theMessage Manager window.
Some of these messages are informational, warning you of potential problems.
The messages may not always require you to perform any action to deal them.

Figure 4-9: Validation Check Dialog Box.
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2. If your validation check looks like the preceding figure, click Close. Otherwise, recheck
your work up to this point.

3. Click Analyze All on the Simulation ribbon tab.

Review Solution Data
1. On the Results ribbon tab, click Solution Data.

The Solutions dialog box appears.

Note:

The subsections that follow describe all of the panels that constitute the Solutions
dialog box. You can review solution data while ananalys is is being solved.

Solving Time
Depending on your computer hardware, solving time can vary considerably. On a 12-core, 3
GHz, Xeon-processor-based PC with 64 GB RAM, this solution took about 2.5 minutes to finish.

Review the Profile Panel
1. On the Solutions dialog box click the Profile tab.

The Profile window provides a synopsis of the different stages of the solution process for
the extraction of electromagnetic field and S, Y, and Z parameter data. The following fig-
ure shows the results ranging frommesh generation, the last two different adaptive
passes, the matrix assembly and the frequency sweep.

For the Profile window shown in the figure, HPC was enabled. The solution converged in
ten passes. Your results may differ slightly. For all the adaptive passes, HFSS employs
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HPC technology using the 12 cores. After convergence is reached the 451 frequency
points are solving in parallel groups.

Figure 4-10: Profile Data Showing Final Adaptive Pass and Beginning of Sweep

2. Leave the Solutions dialog box open and proceed to the next subsection.

Review the Convergence Panel
1. In the Solutions dialog box, click the Convergence tab.

The table showing Convergence data is displayed:
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Figure 4-11: Convergence Data Table

2. Click the Plot option button.

A graph of the convergence data is displayed.

3. Select the X and Y axes for your plot from the drop-down menu as shown in the following
figure:

Figure 4-12: X, Y drop down menus

The plot forMax Mag. Delta S versus Pass Number appears. See figure below.

Note:

Other graphs are displayed as you change the X and Y options from the drop-
down menus.
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Figure 4-13: Convergence Graph

4. Leave the Solutions dialog box open and proceed to the next subsection.

Review Matrix Data Panel
1. Click theMatrix Data tab to view information about the S-parameters. For a real-time

update of the Matrix Data (when the solution is still in progress), set the Simulation
options to Setup1 and Last Adaptive.

Set Up and Analyze the Model 4-12

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS: Bandpass Filter

Figure 4-14: Matrix Data Panel

2. Leave the Solutions dialog box open and proceed to the next subsection.

Review Mesh Statistics Panel
1. Click theMesh Statistics tab to see information about the tetrahedra that were generated

and solved for the individual components.
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Figure 4-15: Mesh Statistics

2. Click Close.
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5 - Evaluate Results
To evaluate the bandpass filter, you will create 2D plots and a field overlay of the simulation res-
ults. This chapter includes the following sections:

l Create S-Parameter vs. Frequency Plot
l Compare S12 with S21
l Change Plot Scale
l Create Field Overlay
l Modify Plot Attributes

Create S-Parameter vs. Frequency Plot
1. In the Project Manager window, right-click Results and select Create Terminal Solution

Data Report > Rectangular Plot from the shortcut menu.

The Report dialog box appears.

2. Specify the settings shown in the following figure:

Evaluate Results 5-1

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS: Bandpass Filter

Figure 5-1: Report Dialog Box

3. Click New Report but leave the Report dialog box open, since you will be adding another
trace to the plot in the next topic.

The Terminal S Parameter Plot 1 appears.

4. Double click on the curve legend.

The Properties dialog box appears.

5. On the Legend tab, clear the Show Solution Name and Show Variation Key options.
6. ClickOK to close the Properties dialog box.
7. Drag the simplified legend to the position shown in the figure below and click in a blank

area of the plot window (outside of the grid area) to clear the axis selection.

The plot should resemble the following figure:
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Figure 5-2: S-Parameter versus Frequency Plot

The figure shows the characteristics of a typical bandpass filter with almost 0dB insertion
loss and reflection of -15dB or less throughout the pass-band.

Compare S12 with S21
You can verify the symmetry of the bandpass filter by comparing S(T1,T2) with S(T2,T1). To do
this, modify the existing S-parameter plot as shown below.

1. If you didn't leave the Report dialog box open in the previous operation, right-click the
existing plot in the Project Manager (Terminal S Parameter Plot 1) and selectModify
Report from the short-cut menu.

The Reports dialog box appears.

2. Enter the following fields:
l Solution: Setup1: Sweep
l Domain: Sweep
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l Quantity: S(T2,T1)
l Function: dB

3. Click Add Trace and click Close.

An additional trace is added to Terminal S Parameter Plot 1. However, you will not be able
to see a third trace, just a change in the color of one curve and an additional entry in the
legend.

Figure 5-3: S Parameter vs Frequency with Third Trace Added

Explanation: The curves dB(St(T2,T1) and dB(St(T1,T2) coincide perfectly, so they look
like a single curve. By hovering the cursor over a trace listed in the curve legend, you can
highlight the curve of interest. The curve color will change to green when the cursor is
pointing to the corresponding trace label in the legend.
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Change Plot Scale
In order to see the noise in the insertion loss you can zoom in to the plot where the S12 curve
plateaus.

To zoom into the area of interest on the plot, change the scale of the Y axis as shown below.

1. Double click the Y-axis.

The Y Axis Properties dialog box appears.

2. On the Y1 Scaling tab, make the following changes:
a. Select the Specify Min option.
b. Type-1 in theMin: text box.
c. Select the Specify Max option.
d. Type0 in theMax: text box.

Figure 5-4: Y1 Scaling Properties
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3. ClickOK and clear the axis selecton.

Your modified plot should resemble the following image:

Figure 5-5: S Parameter vs. Frequency Plot with Modified Y Scaling

Create Field Overlays
This section describes how to create field overlays.

1. In the Project Manager window, right-click Field Overlays and select Edit Sources from
the short-cut menu.

The Edit Sources dialog box appears.

2. Under the Spectral Fields tab, set the options as shown in the following figure (in the
order indicated by the red numbers) and clickOK.
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Figure 5-6: Edit Post Process Sources Dialog Box (Total Voltage Selected)

Note:

Total Voltage includes both the Incident plus Reflected waves in the cal-
culations.

3. Bring theModeler window back to the foreground. You can do so either by closing the plot
window or by using theWindowmenu.

4. Expand Planes near the bottom of the History Tree and selectGlobal:XY.
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5. Right-click in the Modeler window and choose Plot Fields > E >Mag_E from the short-cut
menu.

The Create Field Plot dialog box appears.

6. Set the options as shown in the figure below and click Done.

Figure 5-7: Create Field Plot

Modify Plot Attributes
1. Double-click the legend to modify the E Field plot attributes.

The E Field dialog box appears.

2. Select the Scale tab, set the options as shown in the following figure, and click Close.
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Figure 5-8: E Field Dialog Box (Scale Tab)

The modified field overlay should look like the following image:
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Figure 5-9: Model with Field Overlay

Other Plot Attributes and Animating Results
You may also wish to experiment with available settings on the Color Map tab and the Plots tab
to see how different settings can modify the appearance of the field plot. You can also right-click
theMag_E entry in the Project Manager (under Field Overlays: E Field) and select Animate
from the short-cut menu to animate the simulation.
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6 - Set Up and Run HFSS Multipaction
Analysis

This chapter shows how to run an HFSS Multipaction Analysis using the Bandpass Filter model
just completed. A slight modification of the geometry is required to make the model suitable for
the additional analysis. You will complete the following steps to add and solve the multipaction
analysis:

l Imprint Feed1 and Feed1_1 on the Enclosure
l Assign Secondary Electron Emission (SEE) boundaries to the vacuum/metal interface sur-
faces where multipaction will occur

l Assign multipaction charge region excitations
l Add a discrete sweep as the basis of the multipaction analysis
l Add and Solve the multipaction analysis, specifying a 6 nanosecond duration and four dif-
ferent power multipliers

l Plot the number of particles versus time
l Create and animate a particle overlay
l Create a duplicate HFSS design in the project and add a Multipaction DC bias to the
vacuum objects in the second design

l Solve second multipaction analysis and compare results to first one

For more information, see the HFSSMultipaction Analysis help topic.

Imprint Feeds on Enclosure
In a later procedure, you will aassign an SEE boundary to the outside faces of the enclosure.
However, the Feed1 and Feed1_1 vacuum objects intersect the front and back sides of the
enclosure, respectively. It would be incorrect to place an SEE boundary at the place where two
vacuum parts meet. SEE boundaries represent vacuum-to-metal interfaces where multipaction
effects can occur.

You will use the Imprint tool to split the front and back faces of the enclosure at the feed inter-
sections. The result will be that the areas of intersection become separate enclosure faces, and
you can exclude these small circular faces when assigning the SEE boundary.

1. If the Mag_E field overlay from the HFSS solution is currently visible, do the following:
l Under Field Overlays > E Field in the Project Manager, right-clickMag_E and clear
the Plot Visibility option.

2. Under vacuum in the History Tree, select Enclosure, Feed1, and Feed1_1 (in that spe-
cific order).

3. On the Draw ribbon tab, click Imprint or, using the menu bar, clickModeler >
Boolean > Imprint.
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The Imprint dialog box appears:

Figure 6-1: Imprint Dialog Box

4. Ensure that:
l Enclosure is listed under Blank Parts
l Feed1 and Feed1_1 are listed under Tool Parts

5. Select Clone tool objects before operation.
6. ClickOK.

Note:

Modifying the geometry causes the results of the previously completed HFSS
analysis to be invalidated. This is of no concern. You will choose an option when
setting up the multipaction analysis that will solve the HFSS setup if needed.

7. In Face selection mode, click the front and back faces of the enclosure to verify the imprint-
ing results.

The circular faces at the feed intersections should not be highlighted in magenta, indic-
ating that these faces are excluded from the larger front and back faces:
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Figure 6-2: Imprinting Results Verification

8. Keep these faces selected. In the next procedure, you will select additional faces and
assign the SEE boundary.

Assign SEE Boundaries
The Secondary Electron Emission (SEE) boundaries define vacuum-to-metal interfaces where
secondary electrons will be generated. For this model, the first boundary represents the inside
surfaces of the metal case enclosing the vacuum and conducting parts. This case is not actually
included in the model.

You will also define a second SEE boundary surrounding all of the conducting objects.

For the first SEE boundary, you will select individual faces of the vacuum objects. For the
second, you will select the conducting objects, and the boundary will be applied to all the object
faces.

1. In addition to the front and back faces of the enclosure already selected, hold down the
Ctrl key and click to select the top, bottom, left, and right faces of the enclosure too.
Rotate the view orientation as needed or press B to select a face that is behind an initially
selected face.

2. Holding down Ctrl, also click to select the outside diameter face of each feed.

The model should look like the following image:
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Figure 6-3: Enclosure and Feed SEE Boundary Faces Selected

3. Right-click in the Modeler window and choose Assign Boundary >Multipaction SEE
from the shortcut menu.

TheMultipaction SEE dialog box appears:
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Figure 6-4: Multipaction SEE Dialog Box

4. Verify that the default settings match the preceding figure and clickOK to assign the
boundary.

Figure 6-5: Boundary SEE1 Assigned

5. Click in the background area to clear the current selection.
6. PressO to switch to theObject selection mode.
7. UnderModel > Solids > pec in the History Tree, select Feed1.
8. Shift-click L4 (also underModel > Solids > pec) to select all of the remaining conductor

objects too:

Figure 6-6: Conducting Objects Selected
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9. Right-click in the Modeler window and choose Assign Boundary >Multipaction SEE
10. Again, accept the default settings, as shown in the preceding dialog box figure and click

OK.

Figure 6-7: Boundary SEE2 Assigned

11. Click in the background area to clear the current selection.

Assign Charge Region Excitations
The properties of a multipaction charge region define the initial number of particles and their
charge, mass, and initial velocity components. You will define charge regions with 200 particles
per vacuum object and default values for the remaining properties.

If you were to assign a charge of 600 particles to all three vacuum objects in a single operation,
the number of particles would be distributed uniformly throughout the combined volume of the
selected objects. The majority of the particles would be applied to the largest volume, the enclos-
ure. The density of the particles (number per unit volume) would be constant. For this exercise,
we want to assign a 200 particle charge to each object. Since their volumes differ, two separate
charge region excitations are required. You can assign a charge with 400 particles to the two
feeds in a single operation, since their volumes are identical and both will receive 200 particles.
You will have to apply a 200 particle charge to the enclosure separately.

This excitation scheme creates a higher particle density (that is, a higher charge per unit volume)
within the coaxial feeds than within the enclosure. It is a well known phenomenon among space
component designers that coax feeds are prone to multipaction. Therefore, seeding the feeds
with a higher charge helps multipaction to be detected sooner and therefore leads to a shorter
solution time.
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1. InObject selection mode, or using the History Tree, select Feed1 and Feed1_1.

Figure 6-8: Feed1 and Feed1_1 Selected

2. Right-click in the modeler window and choose Assign Excitation >Multipaction Charge
Region. Then:

a. In theMultipaction Charge Region dialog box that appears, type 400 in the Number
of particles text box.

b. Ensure that the remaining settings match those shown in the following figure:
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Figure 6-9: Multipaction Charge Region Dialog Box – Settings for Feeds

c. ClickOK.

MultipactionChargeRegion1 appears under Excitations in the Project Manager, and
the model appearance is as follows:

Figure 6-10: Multipaction Charge Region 1 Assigned

3. Select the Enclosure object.
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4. Using the menu bar, click HFSS > Excitations > Assign >Multipaction Charge Region.
Then:

a. In theMultipaction Charge Region dialog box that appears, type 200 in the Number
of particles text box.

b. Ensure that the remaining settings match those shown in the following figure:

Figure 6-11: Multipaction Charge Region Dialog Box – Settings for Enclos-
ure

c. ClickOK.

MultipactionChargeRegion2 appears under Excitations in the Project Manager, and
the model appearance is as follows:

Figure 6-12: Multipaction Charge Region 2 Assigned
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5. Click in the background area to clear the current selection.

Add a Discrete Sweep
You will define an additional frequency sweep under analysis Setup1. The fields must be saved
for the sweep to be used as the basis of a multipaction analysis. It is a common practice to create
a separate sweep for this purpose. Saving all fields for a typical frequency sweep would greatly
increase the disk space requirement, since there are generally many frequency points solved to
create smooth S-parameter plots.

For multipaction purposes, three frequency points are generally adequate to cover the range of
a bandpass filter (one near the beginning, one at the middle, and one near the end of the band-
pass frequency range). However, for the purpose of this exercise, you will define a single-point
discrete sweep (1.5 Gz) and review the results for that one frequency.

1. Under Analysis in the Project Manager, right-slick Setup1 and choose Add Frequency
Sweep from the shortcut menu.

2. In the Edit Frequency Sweep dialog box that appears, do the following:
a. SpecifyM_Sweep as the Sweep Name.
b. Choose Discrete from the Sweep Type drop-down menu.
c. Click the Distribution cell and choose Single Point.
d. Type 1.5GHz in the Start cell.
e. Select the Save Fields option in the rightmost column of the table.
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Figure 6-13: Settings for Multipaction Sweep

3. ClickOK to add the multipaction sweep.

M_Sweep appears under Analysis > Setup1 in the Project Manager:

Figure 6-14: M_Sweep in the Project Manager

Add and Solve a Multipaction Analysis
Amultipaction solution is transient. When setting one up, you will define a power sweep, stop
time (event duration), the maximum number of particles, analysis options, and you will set up the
link to the frequency sweep to be used as the basis of the multipaction solution.

1. Under Analysis > Setup1 in the Project Manager, right-clickM_Sweep and choose Add
Multipaction Analysis from the shortcut menu.
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2. In theMultipaction Analysis Setup dialog box that appears, do the following:
a. Choose Single Point in the Distribution cell.
b. Type 100 in the Start cell. This is the first power multiplier to be analyzed.
c. Click Add Below three times so that the Power sweep points table has four rows.
d. Change the Start value for rows 2, 3, and 4 to 200, 400, and 800, respectively.
e. Specify a Stop time of 6 ns.
f. Ensure that Fast multipaction analysis is selected and also select the Charge dis-

tribution option to enable particle overlays.

Figure 6-15: Multipaction Analysis Settings

Keep this dialog box open and proceed to the next step.

3. Near the top of the dialog box, click Setup Link.
4. In the Setup Link dialog box that appears, do the following:
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a. Select the Simulate source design as needed option.
b. Ensure that all settings match those shown in the following figure:

Figure 6-16: Setup Link Settings – General Tab

Since Setup1 and M_Sweep are the only analysis setup and sweep that are applic-
able to a multipaction analysis, the Product, Source Project, Source Design, and
Source Solution settings should already be populated with the appropriate selec-
tions.

5. Select the Excitations tab of the Setup Link dialog box. Then:
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a. Select the Include checkbox for the 1.5 GHz frequency.

Figure 6-17: Setup Link Settings – Excitations Tab

Note:

If the multipaction sweep contains multiple frequencies, and you include
two or more of them in the Setup Link dialog box, the excitations will be
combined. That is, the frequencies will be applied simultaneously resulting
in a very different waveform as compared to a single excitation frequency.

More typically, unless you are truly exciting the device with multiple fre-
quencies simultaneously, you will want to create multiple multipaction ana-
lysis setups, each based on a single excitation frequency.

b. ClickOK to close the Setup Link dialog box.
6. ClickOK to complete the multipaction analysis setup.

Multipaction1 appears under Analysis in the Project Manager:

Figure 6-18: Multipaction1 Added to Project Manager

7. Right-clickMultipaction1 and choose Analyze.

Setup1 will be re-solved, since the original adaptive solution results were invalidated when
you changed the geometry by performing the imprinting operation. The solutions ofM_
Sweep andMultipaction1 will also be completed.

8. Optionally, under Analysis > Setup1 in the Project Manager, right-click Sweep and click
Analyze to restore the frequency sweep results of the original HFSS simulation (those
used for the S-Parameter plots).
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Plot Particles versus Time

1. On the Results ribbon tab, click Multipaction Report > 2D.
2. In the Report dialog box that appears, verify the default settings in the Traces tab, which

are shown in the following image:

Figure 6-19: Multipaction Report Settings – Traces Tab

3. Select the Families tab and ensure that All is specified for the PowerMultiplier variations:

Figure 6-20: Multipaction Report Settings – Families Tab

4. Click New Report and then Close the dialog box.

TheMultipaction Plot 1 window appears.

5. Under Results in the Project Manager, selectMultipaction Plot 1.
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6. In the docked Properties window, change the plot Name toMultipaction Plot - Zero DC
Bias and press Enter.

The plot should resemble the following figure:

Figure 6-21: Multipaction Plot, Particles vs. Time - No DC Bias Applied to Model

Observations:
For power multipliers of 400 and 800, the particle count increases with time.

In a later procedure, you will create a duplicate design but apply a 1000 gauss
DC bias to the vacuum objects to suppress multipaction. You will then compare
the particles vs. time plots of the two designs.
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Create and Animate a Particle Overlay
Next, you will create a particle overlay, choosing the highest power multiplier and the 6 ns time
point. These are the parameters that will produce the greatest particle count.

1. Select the Enclosure, Feed1, and Fee1_1 vacuum objects.
2. Right-click Field Overlays in the Project Manager and choose Plot Particles from the

shortcut menu.
3. In the Create Particles Plot dialog box that appears, do the following:

a. Choose 800 from the Power drop-down menu.
b. Choose 6e-09s from the Time drop-down menu.

Figure 6-22: Create Particles Plot Dialog Box

4. Click Done.
5. Click in the Modeler window background area to clear the current selection.

The particle overlay should resemble the following figure:
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Figure 6-23: Particle Overlay – PowerMultiplier = 800, Time = 6 ns

6. Under Field Overlays > Multipaction plot in the Project Manager, right-clickMultipaction_
Plot1 and choose Animate.

The Create Animation Setup dialog box appears:
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Figure 6-24: Create Animation Setup Dialog Box

7. There is only one variable available as a basis of the animation, Time. All time points are
selected by default.

ClickOK to accept the settings and start the animation.

8. Use the available Animation controls to start, stop, reverse, or adjust the speed of the
animation.

Your animated overlay should resemble the following video clip:
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Figure 6-25: Particle Overlay Animation – PowerMultipler = 800

Observations:
A proliferation of particles is easily seen in the feed regions. By comparison, the
increase in particles within the enclosure is relatively minor but still observable.

Duplicate HFSS Design and Add DC Bias
You will apply a DCmagnetic bias of 1000 gauss (G) to the three vacuum objects to suppress
multipaction effects. Before doing so, you will create a duplicate of HFSSDesign1 to preserve
the results of the zero-bias case.

The magnetic bias is specified in units of electrical current / distance, specifically A/m. The con-
version factor for converting G to A/m is 1000 / (4π). You will specify the magnetic field in the X-
direction. Therefore, the magnetic bias you assign will be as follows:
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We can round that result up to the nearest ten and call it 79,580 A/m.

Duplicate the first design and assign the DC bias as follows:

1. Right-click HFSSDesign1 in the Project Manager and choose Copy from the shortcut
menu.

2. Right-click the project Bandpass_Filter at the top of the Project Manager and chose
Paste.

HFSSDesign2 (Driven Terminal) appears in the Project Manager and becomes the cur-
rently active design.

3. In the Project Manager, collapse the HFSSDesign1 (Driven Terminal branch and
expand the HFSSDesign2 (Driven Terminal) branch.

4. In theWindowmenu, ensure that Bandpass_Filter - HFSSDesign2 - Modeler is the act-
ive window.

5. In theObject selection mode, or using the History Tree, select Feed1, Feed1_1, and
Enclosure.

6. In the Project Manager, right-click Excitations and choose Assign >Multipaction DC
Bias.

7. In theMultipaction DC bias dialog box that appears, do the following:
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a. In the H Field section, specify of Uniform value of 79580 A_per_m for Hx:

Figure 6-26: Multipaction DC Bias Dialog Box

b. ClickOK to assign the specified bias.
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Figure 6-27: Multipaction DC Bias Assigned

Solve 2nd Design and Compare Results
1. Under Analysis in the Project Manager, right-clickMultipaction1 and choose Analyze

from the shortcut menu.

This analysis will typically take less than two minutes to complete.

2. Under Reports in the Project Manager, selectMultipaction Plot – Zero DC Bias.
3. In the docked Properties window, change the plot Name toMultipaction Plot – 1000

Gauss DC Bias and press Enter.
4. In the Project Manager, double-clickMultipaction Plot – 1000 Gauss DC Bias to open

the plot window:

Note:

The limited Y-scale range of this graph is exaggerating the particle count fluc-
tuations. For a fair comparison of these results to those of the zero-bias version
of the model, you must alter the Y-scale to match that of the previous plot.

5. Click the Y-axis of the plot to select it.
6. In the Scaling tab of the docked Properties window, make the following changes:

a. Select Specify Min.
b. Type 0 as theMin value.
c. Select Specify Max.
d. Type 3500 as theMax value and press Enter.

7. Click in the plot window background area to clear the axis selection.
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The modified plot should now resemble the following figure:

Figure 6-28: Multipaction Plot, Particles vs. Time – 1000 Gauss DC Bias Applied to
Model

Compare the preceding plot with the one from the first multipaction analysis. For your con-
venience, the zero-bias plot is included again in the following figure:
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Figure 6-29: Multipaction Plot, Particles vs. Time – No DC Bias Applied to Model

Observations:
The plot with a 1000 G bias applied is very flat as compared to the zero-bias plot.
The addition of the 1000 Gmagnetic bias effectively suppresses multipaction for
all power multipliers considered in the solution.

8. Optionally, display and animate the particle overlay for the second design. You will see
that the particle count and distribution remains fairly constant throughout the simulated
event.

9. Save your project.
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7 - Optionally, Restore Current View
Orientations

You have completed this getting started guide.

If you prefer to use the new view orientations implemented in version 2024 R1 of the Ansys Elec-
tronics Desktop application, clear the Use Legacy View Orientation option as follows:

1. From the menu bar, click View >Options.

The 3D UI Options dialog box appears.

2. Ensure that Enable Legacy View Orientation is cleared:

3. ClickOK.

The settings in the 3D UI Options dialog box are global. Your choice is retained for all future pro-
gram sessions, projects, and design types that use the 3D Modeler or that produce 3D plots of
results.

Optionally, Restore Current View Orientations 7-1
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You can now save and close this project.

Optionally, Restore Current View Orientations 7-2

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.


	Table of Contents
	1 - Introduction
	Bandpass Filter Description
	HFSS Design Environment

	2 - Set Up the Project
	Set General Options
	Insert HFSS design
	Enable Legacy View Orientations
	Set Model Units (in)
	Verify Solution Type (Terminal)


	3 - Create the 3D Model
	Create the Enclosure
	History Tree and Docked Properties Window

	Create Feed1
	Create FeedPin1
	Create FeedProbe1
	Create the Resonators
	Create L1
	Create L2
	Method 1 – Draw Freehand and Revise its Properties
	Method 2 – Copy L1 and Revise the New Object's Properties:

	Create L3
	Create L4

	Assign Excitation
	Create Rest of the Model by Duplication
	Boundary Display (Optional)

	4 - Set Up and Analyze the Model
	Add Solution Setup and Frequency Sweep
	Add HPC Analysis Setup
	What HFSS Does with the HPC Configuration

	Validate and Analyze the Bandpass Filter
	Review Solution Data
	Solving Time
	Review the Profile Panel
	Review the Convergence Panel
	Review Matrix Data Panel
	Review Mesh Statistics Panel


	5 - Evaluate Results
	Create S-Parameter vs. Frequency Plot
	Compare S12 with S21
	Change Plot Scale
	Create Field Overlays
	Modify Plot Attributes
	Other Plot Attributes and Animating Results


	6 - Set Up and Run HFSS Multipaction Analysis
	Imprint Feeds on Enclosure
	Assign SEE Boundaries
	Assign Charge Region Excitations
	Add a Discrete Sweep
	Add and Solve a Multipaction Analysis
	Plot Particles versus Time
	Create and Animate a Particle Overlay
	Duplicate HFSS Design and Add DC Bias
	Solve 2nd Design and Compare Results

	7 - Optionally, Restore Current View Orientations

